User Tools

Site Tools


firmware_upgrade

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Last revision Both sides next revision
firmware_upgrade [2018/11/26 21:54]
akuzmuk created
firmware_upgrade [2020/09/02 12:12]
itkachenko
Line 7: Line 7:
 However, you must bear in mind that an existing project created in a version other than the WebHMI version where it is planned to be installed may not be fully compatible. As a rule, versions with a small difference in numbers in the last positions of the firmware version are compatible 100%, but with a very large version difference, partial compatibility is possible. For example, this was the case when switching from 1.9 to 1.10. Then Lua scripts were added and old visual scripts were removed because they were much less functional. Thus, after downloading the project version to 1.9 to a higher version, it is necessary(if the project used scripts) to write scripts in Lua. However, you must bear in mind that an existing project created in a version other than the WebHMI version where it is planned to be installed may not be fully compatible. As a rule, versions with a small difference in numbers in the last positions of the firmware version are compatible 100%, but with a very large version difference, partial compatibility is possible. For example, this was the case when switching from 1.9 to 1.10. Then Lua scripts were added and old visual scripts were removed because they were much less functional. Thus, after downloading the project version to 1.9 to a higher version, it is necessary(if the project used scripts) to write scripts in Lua.
  
-Another example is a transition from 2.x to 3.x versions3.x uses different OS version (and requires low level access to a device for upgrade), so to upgrade from 2.x to 3.x it was needed contact the supplier. +Another example is a transition from 2.x3.x to 4.x version. 4.x uses different OS version (and requires low level access to a device for upgrade), so to upgrade from 2.x or 3.x to 4.x it was needed contact the supplier. 
  
 Therefore, you should take these points into account before updating. As already mentioned, the neighboring versions are usually 100% compatible, and although a warning is issued when trying to restore a project with an superior version, you can disable this check by checking the 'Ignore check version' flag.  Therefore, you should take these points into account before updating. As already mentioned, the neighboring versions are usually 100% compatible, and although a warning is issued when trying to restore a project with an superior version, you can disable this check by checking the 'Ignore check version' flag.