User Tools

Site Tools


Differences

This shows you the differences between two versions of the page.

Link to this comparison view

firmware_upgrade [2018/11/26 21:54] (current)
akuzmuk created
Line 1: Line 1:
 +===== Firmware upgrade =====
 +
 +WebHMI is constantly evolving and improving. New opportunities are emerging, the old ones can be modified, some become unnecessary and go away, and the identified errors are also corrected. ​
 +
 +So at some point you will decide to upgrade firmware.
 +
 +However, you must bear in mind that an existing project created in a version other than the WebHMI version where it is planned to be installed may not be fully compatible. As a rule, versions with a small difference in numbers in the last positions of the firmware version are compatible 100%, but with a very large version difference, partial compatibility is possible. For example, this was the case when switching from 1.9 to 1.10. Then Lua scripts were added and old visual scripts were removed because they were much less functional. Thus, after downloading the project version to 1.9 to a higher version, it is necessary(if the project used scripts) to write scripts in Lua.
 +
 +Another example is a transition from 2.x to 3.x versions. 3.x uses different OS version (and requires low level access to a device for upgrade), so to upgrade from 2.x to 3.x it was needed contact the supplier. ​
 +
 +Therefore, you should take these points into account before updating. As already mentioned, the neighboring versions are usually 100% compatible, and although a warning is issued when trying to restore a project with an superior version, you can disable this check by checking the '​Ignore check version'​ flag. 
 +
 +{{fw_upgrade.png?​direct}}
 +
 +If you have a replicated solution based on WebHMI and your project works well for a specific firmware version, then so to not waste time in the future to adapt an existing project to a newer firmware, you can simply use the same version in which the project was created. ​
 +
 +  When updating the firmware, the current project is always erased!!!
 +
 +After the upgrade, the project needs to be restored from the previously saved backup. If you have questions about the compatibility of the firmware before upgrading, consult the supplier. ​
 +
 +The prerequisites for the firmware upgrade are:
 +  * **upgrade key** - to obtain the update key, you need to send an email to info@webhmi.com.ua with information about the company, the current version of the firmware, the WebHMI serial number and the version number to which you want to update - (the latest or the specific version in order to preserve the compatibility of the project)
 +  * Make sure that WebHMI has **internet connection**
 +  * Double check that **date and time on WebHMI are correct** - see this [[Time synchronization | link]] on how to do time synchronization.
 +
 +
 +
 +
 +
 +
 +
 +
 +
 +
  

Page Tools